Diamond not working on Mac


New member

unfortunately I have never managed to get Diamond running on my Mac.
Using the make command line, I usually get compilation errors (I have tried several versions of Diamond; there is another thread mentioning this problem).

Lately, I tried to install Diamond using anaconda (https://anaconda.org/bioconda/diamond).
The installation works fine, but unfortunately Diamond still run into problems.
_ the command ''diamond help'' works fine
_ the command ''diamond makedb ... '' works fine as well
_ however the command ''diamond blastp ... '' crashes immediately with a segment fault error
nb: I'm running MacOS High Sierra
nb2: I have repeated several times the blastp command line with the same data on a linux server and it worked fine

this is a bit frustrating.
any help or advice from anybody ?


Benjamin Buchfink

Staff member
Somebody mentioned here that the issue was fixed in the latest commit. Could you please clone the Github repo and try to compile from source again? If there are compilation errors, please paste the output here.


New member
apologies for the late reply.
I just tried to clone the Github repo and to compile from source ... DIAMOND is now working fine on my Mac (High Sierra).

many thanks.